Решения для домашнего онлайн-бизнеса
Описание Купить Поддержка Дополнительно

Технические требования к установке Flapoint Ads

Скрипт нетребователен к ресурсам, может работать практически на любом виртуальном хостинге.

Технические требования к хостингу 

Для работы скрипта Flapoint Ads необходим хостинг с РНР 5 (любые разновидности 5-х версий) и одна база данных MySQL (5 версия)

Если у вас хостинг только с 7 версией PHP (можете узнать у вашего хостера), то тогда проблема решается так: скрипт нужно отдельно установить на другом хостинге с поддержкой РНР 5-х версий. Можно выбрать один из самых дешёвых тарифов - скрипт будет нормально работать. Ему даже ни домен, ни поддомен - не нужен. Какой адрес бесплатно предоставит хостер - с тем и можно работать.

Хостингов с поддержкой РНР 5-х версий - сейчас полным-полно, это не проблема. Большинство крупных известных хостеров предоставляют поддержку РНР 5. Смотрите хостинги с мульти-селекторным PHP, с Cloud Linux, некоторые облачные и т.д. Можно в поисковике ввести соответствующий запрос про поиск хостингов с PHP 5 - получите кучу ссылок.

Кроме того, при покупке скрипта, есть возможность купить не только дистрибутив для самостоятельной установки, но и уже установленную хостинг-версию скрипта. В этом случае, вы получите уже установленный, настроенный к работе Flapoint Ads. Хостинг будет у одного из крупных хостеров и как раз с PHP 5. Помимо данных к доступу к баннерокрутилке Flapoint Ads, вы получите и доступ к хостинговому аккаунту.

Что делать, если вы не знаете, какая версия PHP и MySQL установлены на вашем хостинге?

Если вы не знаете, какая версия PHP и MySQL используется на вашем хостинге, то узнать можно двумя путями:

  1. Посмотреть информацию в вашей панели управления хостингом (или задать вопрос в техподдержку хостинга). 
  2. Самостоятельно определить. Ниже информация, как проверить эти требования.

Предварительно вам нужно создать на своём сайте специальный файл phpinfo.php. Вы можете создать этот файл, например, с помощью Блокнота, а потом загрузить его на ваш хостинг с помощью FTP или же через Панель Управления хостингом. Загружайте в корневую директорию вашего сайта.

Содержимое файла phpinfo.php - всего лишь одна строчка:

phpinfo

Либо отсюда скачайте уже готовый файл с этой строчкой кода, распакуйте и закачайте на свой хостинг.

Этого достаточно, чтобы увидеть практически всю необходимую информацию о Вашем хостинге. После того, как файл загружён на ваш хостинг - наберите в браузере его адрес (вида http://вашсайт.ру/phpinfo.php )

Проверка версии PHP

Версию PHP можно увидеть в самом начале:

Версия PHP

В данном случае, на скриншоте мы видим версию 5.4. Если у вас версия PHP - пятерка любой модификации (например, от 5.0 до 5.6)  - то это подходящая версия для Flapoint Ads.
В случае меньшей версии: PHP 4 - Flapoint Ads тоже с вероятностью в 90% будет работать. Попробуйте. А вот если у вас большая версия, PHP 7, то попробуйте найти в панели управления Вашего хостинга - как изменить версию на меньшую? Или свяжитесь со службой поддержки Вашего хостинга. В крайнем случае, если у вас существует рабочий сайт на PHP 7 и нет возможности изменить версию, то в этом случае нужно ставить скрипт на отдельном хостинге с поддержкой с PHP 5 (в принципе это несложно - в начале этой страницы подробно всё описано).

Версию MySQL можно увидеть далее, примерно в середине страницы

Версия MySQL

Как видим на скриншоте указана пятая версия (одна из модификаций MySQL 5). У вас могут быть другие модификации MySQL 5 - это нормально.

Copyright © flapoint.ru | Пользовательское соглашение | Политика конфиденциальности